安裝 junegunn/vim-plug 管理套件

以指令安裝 junegunn/vim-plug

1
2
curl -fLo ~/.vim/autoload/plug.vim --create-dirs \
    https://raw.githubusercontent.com/junegunn/vim-plug/master/plug.vim

在 ~/.vimrc 加入 Plug ‘ycm-core/YouCompleteMe’

1
2
3
4
5
6
7
" Specify a directory for plugins
call plug#begin('~/.vim/plugged')

Plug 'ycm-core/YouCompleteMe'

" Initialize plugin system
call plug#end()

打開 vim,在 vim 命令列輸入安裝 Plugin 的指令下載 YCM,這個時候還沒編譯所以會顯示安裝失敗

1
:PlugInstall

編譯YCM

安裝編譯工具

1
sudo apt install -y build-essential cmake vim python3-dev 

編譯

1
~/.vim/plugged/YouCompleteMe/install.py

測試

打開 vim 確認,完工~

Reference